The upgrade to the 3.0.5 version is giving error (syntax error.. line 580).

858 viewsUpdates
0

The upgrade to the 3.0.5 version is giving error.

Parse error: syntax error, unexpected ‘[’ in /home/storage/4/e5/ba/hdsystems/public_html/wp_forum/wp-content/plugins/anspress-question-answer/anspress-question-answer.php on line 580

The version of PHP is 5.3.29.

What do I need to solve?

0

This has been answered here 1000 times. Anspress needs PHP 5.5 or later.

Guys PHP 5.3 is very old, why on earth you are using that.

 

https://anspress.io/docs/

edited comment on answer

goDaddy’s Managed WordPress is still on 5.4. Only their cpanel has 5.6. There is no date given when they will upgrade to 5.5 or higher. I am using an old version 2.4.8 of Anspress. No one at goDaddy has an explanation why they can’t give a date.

Nope. You have to ask them for a server that supports PHP 5.5x or greater. This what i hear.

Also Godaddy is nothing to write home about anyway,