How do you display categories?

Solved1.60K viewsThemesaskbug category
0

I have the categories page displayed at  http://trader.help/categories/

But the links do not work. How do I correct this?

Thank you.

Question is closed for new answers.
selected answer
1

Hello Emmett,

Just removing page argument from shortcode did it. As I said many times to remove page argument from shortcode.

Passing a page argument force shortcode to render a specific page.

commented on answer

OH!!! I just needed [anspress] shortcode.

I didnt understand what you meant by “argument”.

Thanks Kumar. It sounds like I need that short code on all of the assigned pages.

0

This is what I have. Should I change something?

commented on answer

Please remove page argument from shortcode.

0

Hello Guys,

First make sure categories page exists and it is selected in AnsPress page setting. If you still get 404 make sure to save WordPress permalinks to flush rewrite cache.

commented on answer

Hi Kumar,

Yes, there is a categories page. And it is selected with the following shortcode inserted: [anspress page="categories"]

I added screenshots to the bottom of this thread. Please take a look.

Thanks,

Emmett

You should not add page=”categories” in shortcode. As current page is already set as categories page in options.
Please send me credentials of your site and let me setup things for you. our email is support@anspress.io

1

Try to save the permalinks again, first the wordpress permalinks (twice).
(Settings -> Permalinks)

After that, go to the anspress option page and save the permalinks there.
(Anspress -> options -> general tab -> permalinks section).

I’m developing a site with this plugin and the askbug theme, and sometimes while I’m moving between versions I get a 404 error, but after I save the permalinks again the problem is solved.