AnsPress Docs

Requirements

There aren’t any special requirements for running AnsPress, just if WordPress is running properly in site, that’s enough for AnsPress. Even though we are listing technical requirements, if anybody wants to know.

WordPress

  1. AnsPress is always updated to work with the latest stable version of WordPress
  2. WordPress 4.2 or above.

Server

Server side requirements. Generally most of hosting account have this by default:

  1. PHP 5.5 or above.
  2. Any version of Apache or nginx.
  3. Any version of MySql.

AnsPress extensions

AnsPress extensions are just WordPress plugin which extends AnsPress functionality and only work if AnsPress is active. You can install and update them as general WordPress plugin. We are listing some must have extensions:

  • Categories for AnsPress – Add category (taxonomy) support for questions.
  • Tags for AnsPress – Add tags (taxonomy) support for questions
  • AnsPress email – Email notification for AnsPress

You can browse all AnsPress extensions here: http://anspress.io/extensions/

WordPress Plugin

Some WordPress plugin which extends the AnsPress functionalities:

  1. WordPress social login – Add social login support in AnsPress.
  2. Crayon Syntax Highlighter – for inserting raw codes in question and answer.

Optional requirements

It’s really not required, but if you are a developer then having these will make your life much easier:

  1. Grunt.js (for compiling LESS and minifying)

Using dashboard

  1. Navigate to the ‘Add New’ in the plugins dashboard
  2. Search for ‘Question labels’
  3. Click ‘Install Now’
  4. Activate the plugin on the Plugin dashboard

Uploading in dashboard

  1. Navigate to the ‘Add New’ in the plugins dashboard
  2. Navigate to the ‘Upload’ area
  3. Select question_labels.zip from your computer
  4. Click ‘Install Now’
  5. Activate the plugin in the Plugin dashboard
Next Topic "FAQ" »